Hello and welcome to our Fiesta ST Forum community! Is this your first visit?
Register

See the top rated post in this thread. Click here

User Tag List

Results 1 to 5 of 5
2 Likes

Thread: ST trip odometer

  1. #1
    New Member
    0%
    Rate Transaction

    Medals
     
    Join Date
    Apr 2017
    City
    Daytona Beach
    State
    FL
    Country
    United States
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    2


    ST trip odometer

    Guest-only advertisement. Register or Log In now!
    I'm in the long habit of using the trip odometer for oil changes but the ST seems to roll back to zero at some predetermined number. This is twice now it's happened, the first time I convinced myself I must have reset it by accident. Does anyone know what this reset number is? Thanks

  2. #2
    Staff Team Staff Team 1251 Rep Points Fiesta ST of the Month Winner D1JL's Avatar
    Ratings | Rate Transaction

    Medals
    Earned First 5 Rep Points Earned First 25 Rep Points Earned First 75 Rep Points Earned First 100 Rep Points  
    Join Date
    Jun 2014
    City
    SFV, So.Cal.
    State
    CA
    Country
    United States
    Posts
    4,849
    Mentioned
    81 Post(s)
    Tagged
    2 Thread(s)
    Likes Received
    1251


    1 Likes

    Not much info on this.
    However, others have complained of the same thing at around 2000-2500 miles on different model cars and trucks.
    Ford's response is that the problem is non-existent.

    I guess the only thing that can be done, would be if more people on this forum run tests.
    Maybe we can then see if the problem affects others.


    Dave
    Modifying cars is a sickness.....and I have it.


    Click The Links Below to See what I Have Done.

  3. #3
    Senior Member 775 Rep Points TyphoonFiST's Avatar
    Ratings | Rate Transaction

    Medals
    Earned First 5 Rep Points Earned First 25 Rep Points Earned First 75 Rep Points Earned First 100 Rep Points  
    Join Date
    Aug 2015
    City
    Blaine
    State
    MN
    Country
    United States
    Posts
    2,889
    Mentioned
    33 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    775


    1 Likes

    Quote Originally Posted by D1JL View Post
    Not much info on this.
    However, others have complained of the same thing at around 2000-2500 miles on different model cars and trucks.
    Ford's response is that the problem is non-existent.

    I guess the only thing that can be done, would be if more people on this forum run tests.
    Maybe we can then see if the problem affects others.


    Dave
    I will verify that it resets around 2500 miles on my 15' as I was hoping to use it on my Florida Keys trip for a total mileage tracker.....Nope reset itself...I wasn't impressed.....did it on the way home also.
    Is this your bush? Are you king of the forest?

  4. #4
    Member 324 Rep Points XR650R's Avatar
    Ratings | Rate Transaction

    Medals
    Earned First 5 Rep Points Earned First 25 Rep Points Earned First 75 Rep Points Earned First 100 Rep Points  
    Join Date
    Aug 2014
    City
    Eerie
    State
    IN
    Country
    United States
    Posts
    536
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    324


    Quote Originally Posted by TyphoonFiST View Post
    I will verify that it resets around 2500 miles on my 15' as I was hoping to use it on my Florida Keys trip for a total mileage tracker.....Nope reset itself...I wasn't impressed.....did it on the way home also.
    I had the same experience on a long trip. I think it reset @ about 2000.
    2017 Magnetic, everything but the Recaros. MP 215, mountune shift kit and shift knob, Husky floor liners. That's all I'm doing, I swear!.. OK, I lied. Also added an intake hose and symposer delete. But that really is all, I swear this time! Okay. just one other thing: A mountune RMM. Now I really am done, I promise!

  5. #5
    New Member 7 Rep Points METZGER's Avatar
    0%
    Rate Transaction

    Medals
    Earned First 5 Rep Points  
    Join Date
    Nov 2017
    City
    Melbourne
    Country
    Australia
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    7


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by rzracer View Post
    I'm in the long habit of using the trip odometer for oil changes but the ST seems to roll back to zero at some predetermined number. This is twice now it's happened, the first time I convinced myself I must have reset it by accident. Does anyone know what this reset number is? Thanks
    Haha yea I am glad to see someone else has experienced this too... I had same problem and I was like wtf.. a fully digital system and it can't let it go past a couple thousand... Pretty stupid IMO.

    Sent from my Mi MIX 2S using Tapatalk


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •