Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

User Tag List

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    New Member 8 Rep Points
    0%
    Rate Transaction

    Member #
    9877
    Medals
     
    Join Date
    Apr 2018
    Location
    Shalimar
    State
    Non-US
    Country
    United States
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    8


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by redmoe View Post
    Man that sucks! Did you happen to run the car through an automated carwash? I was thinking about wing risers but those brushes made me think twice.
    I never use automated carwash. You are right to fear those brushes as they can tear up paint. Our paint isn't very good to begin with.

    Sent from my SM-G955U using Tapatalk

  2. #12
    New Member 8 Rep Points
    0%
    Rate Transaction

    Member #
    9877
    Medals
     
    Join Date
    Apr 2018
    Location
    Shalimar
    State
    Non-US
    Country
    United States
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    8


    Quote Originally Posted by Jerickson88 View Post
    I’ve always been curious if this would happen so I’ve held off on doing it. Where are you located? Do you think heat exposure could do this?
    I'm located in the Panhandle. I do not believe heat is/was an issue. I feel it's more likely a vibration issue and maybe overtightening. I say vibration due to the opening and closing of the hatch. Regarding tightening, it can be difficult to find the sweet spot when tightening. You are mating metal to cheap plastic.

    Sent from my SM-G955U using Tapatalk

  3. #13
    New Member 8 Rep Points
    0%
    Rate Transaction

    Member #
    9877
    Medals
     
    Join Date
    Apr 2018
    Location
    Shalimar
    State
    Non-US
    Country
    United States
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    8


    Quote Originally Posted by TyphoonFiST View Post
    I think it's a vibration issue and overtightening.

    Sent from my SM-N950U1 using Tapatalk
    I agree on the former more than the latter. I love the look but I dont want to get another OEM spoiler just to have this happen again. I'm looking at the Delta style from Whoosh. $$$

    Sent from my SM-G955U using Tapatalk

  4. #14
    New Member 8 Rep Points
    0%
    Rate Transaction

    Member #
    9877
    Medals
     
    Join Date
    Apr 2018
    Location
    Shalimar
    State
    Non-US
    Country
    United States
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    8


    Quote Originally Posted by kivnul View Post
    My son has this setup and his wing broke somewhat similarly during installation. I had some epoxy putty on hand and filled the section of wing up with it smushing the broken bit down into it. I also used super glue on where the plastic bits touch to seal up the edge. It seemed to work fine. I did notice with this setup that you have to be very careful during the install to keep everything loose until you are certain that everything lines up and sits down flush. If you don't you will have a connection that had too much stress on it compared to the others. Good luck.
    Great points! I may use this advice in repairing mine. Any brand/type of epoxy you recommend?

    Sent from my SM-G955U using Tapatalk

  5. #15
    New Member 8 Rep Points
    0%
    Rate Transaction

    Member #
    9877
    Medals
     
    Join Date
    Apr 2018
    Location
    Shalimar
    State
    Non-US
    Country
    United States
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    8


    Quote Originally Posted by HABANERO_ST View Post
    that happend to me also, i took everything of and used locktite to keep thing from loosening, haven't had an issues sense, i check it often because i have the vm wing on it to.
    Vm wing?

    Sent from my SM-G955U using Tapatalk

  6. #16
    Member 154 Rep Points kivnul's Avatar
    Ratings | Rate Transaction

    Member #
    4220
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Jan 2016
    Location
    Deer Park
    State
    WA
    Country
    United States
    Posts
    464
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    154


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by Toofless ST View Post
    Great points! I may use this advice in repairing mine. Any brand/type of epoxy you recommend?

    Sent from my SM-G955U using Tapatalk
    Loctite makes two different puttys, I think this is the one I used.

    Loctite Putty

    I just cut an inch off the log with a razor, kneed it with my hands until uniform and start cramming it in the hole. I left some room for it to expand into the wing further and heaped it up in the middle so when the two pieces are pushed together the epoxy forms around them both. Good luck.

 

 
Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •