Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

See the top rated post in this thread. Click here

User Tag List

Page 4 of 5 FirstFirst 12345 LastLast
Results 31 to 40 of 50
  1. #31
    Member 49 Rep Points maestromaestro's Avatar
    0%
    Rate Transaction

    Member #
    2565
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Apr 2015
    Location
    Houston
    State
    TX
    Country
    United States
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    49


    Guest-only advertisement. Register or Log In now!
    If it were an automatic, that'd be one thing. Pressing the brake - I wonder if the pedal touched something loose? On the other hand, is there a short of some kind that involves the braking circuit?

    Have you tried unplugging the ECU harnesses?
    Stage 3 2015: Cobb FMIC + APort&Tuner + Cobb RMM + Ingen CAI + ATP charge pipe + 2JR catless DP + 3" inch Ingen exhaust/custom 3" flange for DP + Mishimoto Radiator + Mishimoto Oil Cooler : Sympozer delete : Boomba shifter bushings/short throw adapter : Wilwood Big/Brake Kits on all 4 corners and Timken rear hubs : Willwood Spec 37 slotted rotors; 4x100 bolting pattern conversion : Boomba Brake Cooling Deflectors : BC-2 Coilovers and Springs - 1" lower : TB Performance brace, crossmemeber and rear traction bar : NoPistons dead pedal : Euro smoked LED tailights : Strobe 3rd brake light :Rally Mud Flaps : Sanded front grille honeycomb : Auxbeam® 7" fog lights : Piercemotorsports front tow hook : SYNC 3 conversion with Android Auto/Apple Car Play : Rear view backup camera : Speed Dawg shift knob : JL Audio JX400/4D 4-channel amplifier : KICKER 11HS8 8" 150W Subwoofer : AudioControl LC2i 2 : Infinity 6-1/2 Inch Coaxial Speakers : Polk Audio Speakers : Schroth Rallye 4 ASM harness +...

  2. #32
    Senior Member 1117 Rep Points TyphoonFiST's Avatar
    Ratings | Rate Transaction

    Member #
    3563
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 2000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points Earned First 2000 Posts and 400 Rep Points
    Join Date
    Aug 2015
    Location
    Rich-fizzield
    State
    MN
    Country
    United States
    Posts
    3,860
    Mentioned
    38 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    1117


    Quote Originally Posted by zanethan View Post
    Well the plot thickens. It did it again tonight coming back from some friends. This time I couldn’t get it to restart for a solid 10 minutes. Out of frustration I tried starting it again while pushing the brake and presto fired right up. It stalled a few more times and would not turn over until I also pressed the brake while starting. Got it back home and of course, all is normal. I do have a check engine light now P2610 (ECU/PCU off timing). I also tried unplugging both the sensors to see if that would trigger the symptoms but it didn’t. What is semi alarming is that even with both sensors u plugged there were NO dash warning lights but maybe those are just tail light switches. So this has me thinking it’s brake system related in someway shape or form. Anyone have any pointers from here??
    Call Ford and find out if there is a TSB for that code... it has to do with the PCM/ECM engine timer....it could need to be flashed or replaced. It could also be a CKP/Cranshaft position sensor failing intermittently. You would have to drive the vehicle with live feed data recording and see if you can watch the CKP fall on its face. These are my thoughts....




    Sent from my SM-N950U1 using Tapatalk
    Last edited by TyphoonFiST; 02-10-2019 at 10:55 PM.
    Is this your bush? Are you king of the forest?

  3. #33
    Member 100 Rep Points blurred's Avatar
    0%
    Rate Transaction

    Member #
    2176
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Feb 2015
    Location
    Toronto
    Country
    Canada
    Posts
    279
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    100


    Fix the p0504 Brake switch/p2127 accelerator pedal position sensor first. Everything else should be fine after. Your car seems to be in gas plus brake mode (what it feels like after a few seconds of left foot braking) because it can no longer sense if you are touching the brake pedal and Ford doesn't want you to PriusCop yourself into a wall while holding both the brake and gas.

    That's my GUESS anyways....

  4. #34
    Member 49 Rep Points maestromaestro's Avatar
    0%
    Rate Transaction

    Member #
    2565
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Apr 2015
    Location
    Houston
    State
    TX
    Country
    United States
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    49


    Quote Originally Posted by blurred View Post
    Fix the p0504 Brake switch/p2127 accelerator pedal position sensor first. Everything else should be fine after. Your car seems to be in gas plus brake mode (what it feels like after a few seconds of left foot braking) because it can no longer sense if you are touching the brake pedal and Ford doesn't want you to PriusCop yourself into a wall while holding both the brake and gas.

    That's my GUESS anyways....
    It wasn't a Prius - a Lexus. And he never actually pressed the brakes. Hit a ditch.

    I like your suggestion tho.
    Stage 3 2015: Cobb FMIC + APort&Tuner + Cobb RMM + Ingen CAI + ATP charge pipe + 2JR catless DP + 3" inch Ingen exhaust/custom 3" flange for DP + Mishimoto Radiator + Mishimoto Oil Cooler : Sympozer delete : Boomba shifter bushings/short throw adapter : Wilwood Big/Brake Kits on all 4 corners and Timken rear hubs : Willwood Spec 37 slotted rotors; 4x100 bolting pattern conversion : Boomba Brake Cooling Deflectors : BC-2 Coilovers and Springs - 1" lower : TB Performance brace, crossmemeber and rear traction bar : NoPistons dead pedal : Euro smoked LED tailights : Strobe 3rd brake light :Rally Mud Flaps : Sanded front grille honeycomb : Auxbeam® 7" fog lights : Piercemotorsports front tow hook : SYNC 3 conversion with Android Auto/Apple Car Play : Rear view backup camera : Speed Dawg shift knob : JL Audio JX400/4D 4-channel amplifier : KICKER 11HS8 8" 150W Subwoofer : AudioControl LC2i 2 : Infinity 6-1/2 Inch Coaxial Speakers : Polk Audio Speakers : Schroth Rallye 4 ASM harness +...

  5. #35
    Member 100 Rep Points blurred's Avatar
    0%
    Rate Transaction

    Member #
    2176
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Feb 2015
    Location
    Toronto
    Country
    Canada
    Posts
    279
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    100


    Quote Originally Posted by maestromaestro View Post
    It wasn't a Prius - a Lexus. And he never actually pressed the brakes. Hit a ditch.

    Would still win a Darwin award if it was a prius and/or a wall

  6. #36
    Member 184 Rep Points zanethan's Avatar
    0%
    Rate Transaction

    Member #
    5941
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Sep 2016
    Location
    Charlotte
    State
    Non-US
    Country
    United States
    Posts
    532
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    184


    Quote Originally Posted by blurred View Post
    Fix the p0504 Brake switch/p2127 accelerator pedal position sensor first. Everything else should be fine after. Your car seems to be in gas plus brake mode (what it feels like after a few seconds of left foot braking) because it can no longer sense if you are touching the brake pedal and Ford doesn't want you to PriusCop yourself into a wall while holding both the brake and gas.

    That's my GUESS anyways....
    Where would I start with the brake switch code? What sensor would trigger that?

  7. #37
    Staff Team Staff Team 1454 Rep Points Fiesta ST of the Month Winner D1JL's Avatar
    Ratings | Rate Transaction

    Member #
    879
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 2000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points Earned First 2000 Posts and 400 Rep Points Earned First 5000 Posts and 500 Rep Points
    Join Date
    Jun 2014
    Location
    SFV, So.Cal.
    State
    CA
    Country
    United States
    Posts
    5,273
    Mentioned
    85 Post(s)
    Tagged
    2 Thread(s)
    Likes Received
    1454


    Quote Originally Posted by zanethan View Post
    Where would I start with the brake switch code? What sensor would trigger that?
    You could just enter P0504 into your internet search box.

    If you are trying to fix your own car, I would suggest first buying a service manual.
    Maybe you might need some specialized electronic tools, like a multimeter or for code timing issues, an oscilloscope.

    Sometimes it may be best to seek professional help, it may even be cheaper in the long run.

    I know that many here have and will try to help you but it is almost impossible to fix a car by remote control.
    Modifying cars is a sickness.....and I have it.


    Click The Links Below to See what I Have Done.

  8. #38
    Member 184 Rep Points zanethan's Avatar
    0%
    Rate Transaction

    Member #
    5941
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Sep 2016
    Location
    Charlotte
    State
    Non-US
    Country
    United States
    Posts
    532
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    184


    Car died and wouldn’t go over 1000Rpm or 5mph

    Quote Originally Posted by D1JL View Post
    You could just enter P0504 into your internet search box.

    If you are trying to fix your own car, I would suggest first buying a service manual.
    Maybe you might need some specialized electronic tools, like a multimeter or for code timing issues, an oscilloscope.

    Sometimes it may be best to seek professional help, it may even be cheaper in the long run.

    I know that many here have and will try to help you but it is almost impossible to fix a car by remote control.
    Do you seriously think I didn’t start with searching that code? In fact that’s where I started. Hardly any other Fiesta owners have encountered that code (or at least few have posted about it) and since it’s a general power train code I was seeing if ‘blurred’ had a more specific place to start narrowing it down. I’m not trying to be lazy and leech off of members but I thought the point of this forum was to collectively gather experiences and issues related to our platform. I guess I’m just the first Fiesta owner to experience this exact issue. Lucky me!

    Car has been sent to the dealer at this point as yes, I agree, diagnosing this is above my mechanical abilities.

    I’m not sure why I’m drawing your ire I’m just trying to narrow down what others are suggesting and put my threads in the proper sub forums for future members that experience this issue.

    I must admit I expect more out of a moderator on this forum especially in regards to a productive and active member of this community for over 2 years. Sure, I certainly wasn’t the nicest during the ProDigit/MeLee debacle but I’ve since apologized for that and stayed well out of his threads.

  9. #39
    Staff Team Staff Team 1454 Rep Points Fiesta ST of the Month Winner D1JL's Avatar
    Ratings | Rate Transaction

    Member #
    879
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 2000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points Earned First 2000 Posts and 400 Rep Points Earned First 5000 Posts and 500 Rep Points
    Join Date
    Jun 2014
    Location
    SFV, So.Cal.
    State
    CA
    Country
    United States
    Posts
    5,273
    Mentioned
    85 Post(s)
    Tagged
    2 Thread(s)
    Likes Received
    1454


    I don't know why you think I am the bad guy here.

    I did shut down the other thread as it was not necessary to have the same thing in two locations (my job here).

    However I did read the thread and saw that you were getting executant suggestions.
    But your last comment was what I was referring to.

    "Where would I start with the brake switch code? What sensor would trigger that?"

    So I suggested that you look it up on the internet because it is there (I just looked it up).
    And then tried to point out that the cost of some tools (I know, I have them) may be more than taking it to a shop.

    My last comment was based on my own personal experience.
    As a retired ASE Master Tech. I know how hard it is to repair a car by remote.
    I also know that intermittent problems are the worst to diagnose.

    So in all, I was just trying to help you.
    Maybe I should stop doing that.
    I didn't see you lashing out at anyone else's suggestions.
    But then I am sure that you are frustrated with the problems you are having.


    Good Luck
    Modifying cars is a sickness.....and I have it.


    Click The Links Below to See what I Have Done.

  10. #40
    Member 184 Rep Points zanethan's Avatar
    0%
    Rate Transaction

    Member #
    5941
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Sep 2016
    Location
    Charlotte
    State
    Non-US
    Country
    United States
    Posts
    532
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    184


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by D1JL View Post
    I don't know why you think I am the bad guy here.

    I did shut down the other thread as it was not necessary to have the same thing in two locations (my job here).

    However I did read the thread and saw that you were getting executant suggestions.
    But your last comment was what I was referring to.

    "Where would I start with the brake switch code? What sensor would trigger that?"

    So I suggested that you look it up on the internet because it is there (I just looked it up).
    And then tried to point out that the cost of some tools (I know, I have them) may be more than taking it to a shop.

    My last comment was based on my own personal experience.
    As a retired ASE Master Tech. I know how hard it is to repair a car by remote.
    I also know that intermittent problems are the worst to diagnose.

    So in all, I was just trying to help you.
    Maybe I should stop doing that.
    I didn't see you lashing out at anyone else's suggestions.
    But then I am sure that you are frustrated with the problems you are having.


    Good Luck
    Ah the issues of trying to decipher inflection via text. Your comment of ‘Or you could just search the code in the internet box’. Came off as smart a**y to me but you clearly didn’t intend for it to have been meant in that way.

    My apologies for lashing out I just thought you were accusing me of being lazy and not wanting to do any research which I can assure you I’m not trying to do.

    As I said I dropped it off at the dealer since it’s happening with the factory tune and throwing some codes again so hopefully it’s something as easy as a faulty throttle position sensor.

    Again my apologies for lashing out I put my own emotion into your text.

 

 
Page 4 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Horn died
    By CSM in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 5
    Last Post: 11-15-2018, 09:20 PM
  2. My FiST died!
    By Tethlah in forum Off Topic Discussions
    Replies: 11
    Last Post: 06-26-2016, 09:29 PM
  3. FiST Died Randomly & Won't Start
    By Chris G in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 32
    Last Post: 05-29-2015, 01:49 PM
  4. Nav/Radio/Display died on me today
    By TheStig in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 11
    Last Post: 09-06-2014, 12:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •