Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

User Tag List

Results 1 to 4 of 4
  1. #1
    Member 310 Rep Points Clit_Beastwood's Avatar
    0%
    Rate Transaction

    Member #
    8822
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points
    Join Date
    Oct 2017
    Location
    Laguna beach
    State
    CA
    Country
    United States
    Posts
    678
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    310


    If the passenger side mount is squeaky, is it already "gone"?

    Guest-only advertisement. Register or Log In now!
    Mine is doing a veeeeeery slight version of this -> https://www.youtube.com/watch?time_c...&v=vk5L3d2F0hQ

    I ordered the pineapple slice and bolt from Whoosh, but I was wondering if the squeaking indicates the mount is already shot.
    Thoughts? The engine doesn't move much by hand, I only started researching this because my car gets a case of the squeakies when cold. I've also noticed a pronounced increase in audible mechanical noise (whirring while coming to a stop, more audible injector noise, etc.). Researching an increase in mechanical noise led me down the path of the passenger mount - I'd be surprised if it's dead in a car with 13k used as a daily driver, but... :shrug:

    If anyone has any idea how to check the mount without pulling it completely, let me know. I tried to get in there one handed and I can't quite pull it off.

  2. #2
    Member 153 Rep Points
    Ratings | Rate Transaction

    Member #
    9334
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Jan 2018
    Location
    lakewood
    State
    CA
    Country
    United States
    Posts
    458
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    153


    those mounts were F-ed up they must have did some work on them to screw them up so bad. anything for a sale. spray a little lube on there and see if it goes away. I think the r/s mm has oil in the bottom half so look if their is a leak. I put both mount inserts on mine but i'm not finished yet. you could try a turn on the stock bolt to see if its loose. good luck

  3. #3
    Member 310 Rep Points Clit_Beastwood's Avatar
    0%
    Rate Transaction

    Member #
    8822
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points
    Join Date
    Oct 2017
    Location
    Laguna beach
    State
    CA
    Country
    United States
    Posts
    678
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    310


    Quote Originally Posted by dmb View Post
    those mounts were F-ed up they must have did some work on them to screw them up so bad. anything for a sale. spray a little lube on there and see if it goes away. I think the r/s mm has oil in the bottom half so look if their is a leak. I put both mount inserts on mine but i'm not finished yet. you could try a turn on the stock bolt to see if its loose. good luck
    Thanks! That squeaky sound is driving me nuts :P for a long time I thought it was my exhaust hangers squeaking - I could grab the exhaust and move it around and that squeaking came from the mount under the hood. I mistook it for exhaust hanger squeaks so i took the time to teflon-tape the hangers and add silicone grease to the "hooks". It *did* make things a little quieter, but the under hood squeakies were still there. It's not a huge deal, but I have fixated on the squeaking and the only cure is to remove the squeaks, I won't be able to enjoy myself until I address it. I will obsess over it until I get it to stop squeaking :P

  4. #4
    New Member 7 Rep Points
    0%
    Rate Transaction

    Member #
    11241
    Medals
     
    Join Date
    Jan 2019
    Location
    Ashburn
    State
    VA
    Country
    United States
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    7


    Guest-only advertisement. Register or Log In now!
    I get a lot of squeaking under my hood somewhere too. I was gonna use it as an excuse to "accidentally" get a RMM, but I guess I'll do the fiscally responsible thing and grease up the other mounts first.

    Sent from my H3123 using Tapatalk

 

 

Similar Threads

  1. Side-view Mirrors will not tilt "down"
    By winniethepujals in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 1
    Last Post: 05-04-2018, 06:22 PM
  2. squeaky noise front passenger side
    By ikspeekju in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 38
    Last Post: 03-22-2018, 11:42 AM
  3. Replies: 3
    Last Post: 08-28-2017, 06:59 AM
  4. Replies: 6
    Last Post: 05-11-2016, 12:02 PM
  5. Chai's "SuperClean" to "BlackMamba" to "TOUGEMNSTR" Build
    By Chai in forum Fiesta ST Build Projects
    Replies: 5
    Last Post: 01-20-2015, 08:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •