Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

User Tag List

Results 1 to 10 of 10
  1. #1
    New Member
    0%
    Rate Transaction

    Member #
    10932
    Medals
     
    Join Date
    Nov 2018
    Location
    orlando
    State
    FL
    Country
    United States
    Posts
    28
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    3


    Both keyfobs lost connection?

    Guest-only advertisement. Register or Log In now!
    So this morning on my way to work, car unlocked and started fine. I saw my cars temperature was in Celsius, not Fahrenheit, and thought that was odd. Also, noticed the airbag light was on. I thought I'll just restart my car when I get to work and hopefully everything resets. When I pushed off, it took a while for the car to turn off, longer than usual lol. After that, car seemed to be 'dead'. Wouldn't start or power locks. Lights worked, battery not dead. Retrieved my second key from home, that didn't work. My car is sitting at the dealer now, hopefully it's an easy fix. Just wondering if anyone else had this issue? My car is an '18 with 2800 miles, so a bit uneasy that I'm already experiencing issues with the new technology.
    stock '18 Fiesta ST - shadow black

  2. #2
    New Member 10 Rep Points
    0%
    Rate Transaction

    Member #
    11379
    Medals
     
    Join Date
    Feb 2019
    Location
    Suffolk
    State
    AR
    Country
    United States
    Posts
    29
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    10


    Quote Originally Posted by scawt View Post
    So this morning on my way to work, car unlocked and started fine. I saw my cars temperature was in Celsius, not Fahrenheit, and thought that was odd. Also, noticed the airbag light was on. I thought I'll just restart my car when I get to work and hopefully everything resets. When I pushed off, it took a while for the car to turn off, longer than usual lol. After that, car seemed to be 'dead'. Wouldn't start or power locks. Lights worked, battery not dead. Retrieved my second key from home, that didn't work. My car is sitting at the dealer now, hopefully it's an easy fix. Just wondering if anyone else had this issue? My car is an '18 with 2800 miles, so a bit uneasy that I'm already experiencing issues with the new technology.
    That's very odd

    Sent from my SM-N910V using Tapatalk

  3. #3
    Member 133 Rep Points Zormecteon's Avatar
    0%
    Rate Transaction

    Member #
    4133
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Dec 2015
    Location
    Kelso
    State
    WA
    Country
    United States
    Posts
    434
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    133


    The test of a battery is not "the lights work".. the test is to honk the horn. .. sounds to me like a weak battery. . ..having to take longer than usual to start --not firing right away --- is a sign... probably used up what was left of the charge. .. (I recently had to replace my battery after similar circumstances.
    mountune mods;... Mp215, High Flow Induction Hose,Complete Intercooler Upgrade,Silicone Coolant Hoses, Quick Shift Kit, Spring Set, Rear Motor Mount, Front Shock Tower Brace and a Mishimoto Trunk Brace.

  4. #4
    New Member
    0%
    Rate Transaction

    Member #
    10932
    Medals
     
    Join Date
    Nov 2018
    Location
    orlando
    State
    FL
    Country
    United States
    Posts
    28
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    3


    Quote Originally Posted by Zormecteon View Post
    The test of a battery is not "the lights work".. the test is to honk the horn. .. sounds to me like a weak battery. . ..having to take longer than usual to start --not firing right away --- is a sign... probably used up what was left of the charge. .. (I recently had to replace my battery after similar circumstances.
    tried jumping it with a battery pack. also nothing on either of the keyfobs functioned.
    stock '18 Fiesta ST - shadow black

  5. #5
    Member 49 Rep Points
    Ratings | Rate Transaction

    Member #
    4516
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Feb 2016
    Location
    Morton Grove
    State
    IL
    Country
    United States
    Posts
    272
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    49


    Following
    Mountune MRX turbo, Mountune CBE, Mountune Intake, Ramair crossover, Deporacing DP, Deporacing IC, Damond OCC,Cobb RMM, and tuned by Tune+.

  6. #6
    New Member
    0%
    Rate Transaction

    Member #
    10932
    Medals
     
    Join Date
    Nov 2018
    Location
    orlando
    State
    FL
    Country
    United States
    Posts
    28
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    3


    Quote Originally Posted by Ceecab705 View Post
    Following
    UPDATE: they're replacing either the bcm or pcm
    stock '18 Fiesta ST - shadow black

  7. #7
    Member 49 Rep Points
    Ratings | Rate Transaction

    Member #
    4516
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Feb 2016
    Location
    Morton Grove
    State
    IL
    Country
    United States
    Posts
    272
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    49


    Thank goodness you're still under warranty.
    Mountune MRX turbo, Mountune CBE, Mountune Intake, Ramair crossover, Deporacing DP, Deporacing IC, Damond OCC,Cobb RMM, and tuned by Tune+.

  8. #8
    New Member 18 Rep Points METZGER's Avatar
    0%
    Rate Transaction

    Member #
    8989
    Medals
     
    Join Date
    Nov 2017
    Location
    Melbourne
    Country
    Australia
    Posts
    85
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    18


    Yea that's weird.. I have replaced both my key fob batteries once in 4 years from brand new that's the only issue I have had, mine is a 2014 ST3.

    Sent from my Mi MIX 2S using Tapatalk

  9. #9
    New Member 5 Rep Points
    0%
    Rate Transaction

    Member #
    10842
    Medals
     
    Join Date
    Oct 2018
    Location
    RESTON
    State
    VA
    Country
    United States
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    5


    Quote Originally Posted by scawt View Post
    UPDATE: they're replacing either the bcm or pcm
    Or they're reflashing one of them. They did that to my BCM after similar symptoms. And it's been fine since. (2018 with 3100 miles; electronic gremlins briefly visitee at about 2000 ,iles.)

  10. #10
    Senior Member 428 Rep Points
    Ratings | Rate Transaction

    Member #
    5184
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points
    Join Date
    Jun 2016
    Location
    South West Ohio
    State
    OH
    Country
    United States
    Posts
    1,576
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    428


    Guest-only advertisement. Register or Log In now!
    Temperature and airbag (among other things) are under the control of the Body Control Module. Such issues are typically power or ground related. Batteries are often run low or dead at the dealership... and things get a little wonky when someone attempts to incorrectly jump the vehicle on a flat battery.

    As a test to confirm a permanent fix, I'd disconnect the battery overnight. If it's a programming glitch, the reflash should do it though.
    2016 Ford Fiesta ST Kona Blue ; Engine, Suspension will remain untouched ; Southwest Ohio ; Winter: 215/45R17 Continental ; Seasonal: 205/40R17 Bridgestone

 

 

Similar Threads

  1. Bluetooth Connection Issues
    By MichiganST in forum Audio-Video, Electronics, Sync & MyFord Touch
    Replies: 23
    Last Post: 02-01-2018, 05:50 PM
  2. Help with meaning of gas and such please lost.
    By Giovan0406 in forum New Member Introduction
    Replies: 7
    Last Post: 08-23-2017, 10:41 PM
  3. Mystery airbox hose connection
    By Fistfan in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 5
    Last Post: 04-15-2017, 08:15 PM
  4. 2014 FiST with Nav - Low/No Volume through speakers with bluetooth iPhone connection
    By Waterfan in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 7
    Last Post: 06-09-2016, 06:06 PM
  5. Missed Connection (Humor)
    By William.LEJA in forum Off Topic Discussions
    Replies: 2
    Last Post: 04-24-2015, 10:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •