Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

User Tag List

Results 1 to 10 of 10
  1. #1
    New Member
    0%
    Rate Transaction

    Member #
    11455
    Medals
     
    Join Date
    Mar 2019
    Location
    Greenbrier
    State
    TN
    Country
    United States
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    Strange boost issue - During WOT pull, peaks at 20, then drops to 15, and repeats. Car has a secondary DV also, why?

    Guest-only advertisement. Register or Log In now!
    I bought a Fiesta FT over the weekend with mods from someone that bought it from an auction to flip, so I'm not sure what's going on with the mods. I'm having to track them down.

    Anyway, the car has upgraded intercooler, exhaust, and wastegate, but what puzzles me is the added diverter valve. I haven't checked to see if the OEM DV is still installed, but the one in the photo is also installed. Any idea why and who makes it?

    Also, why at WOT would the car reach peak boost and drop then peak again? I don't think it's a boost leak, but I could be wrong. I had a Focus ST with a hole in a boost hose and it never cycled on peak boost it just maintained a lower peak. Thanks
    Attached Images Attached Images   

  2. #2
    Member 77 Rep Points
    0%
    Rate Transaction

    Member #
    8663
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points
    Join Date
    Sep 2017
    Location
    Pleasant Hill
    State
    CA
    Country
    United States
    Posts
    300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    77


    That's a Mountune symposer delete plug. Shouldn't be an issue as long as the plugs for the fittings were sealed correctly (can't tell from the photo)
    - Mountune RMM, Quick Shift kit, SS brake lines, radiator, exhaust hangers, induction hose, FMIC
    - Koni Sport struts, Swift springs, Enkei RPF1s, Conti ExtremeContact Sports
    - StopTech slotted rotors, Carbotech 1521 pads
    - Pierce 2-pt chassis brace
    - Hotchkis rear anti-roll bar
    - Green air filter
    - Ford carbon fiber shift knob
    - Radium catch can

  3. #3
    Member 93 Rep Points CarGuy's Avatar
    Ratings | Rate Transaction

    Member #
    17
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points
    Join Date
    Jul 2013
    Location
    Makawao
    State
    HI
    Country
    United States
    Posts
    418
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    93


    Quote Originally Posted by green_henry View Post
    That's a Mountune symposer delete plug. Shouldn't be an issue as long as the plugs for the fittings were sealed correctly (can't tell from the photo)
    What he said. That's exactly what it is.

    Sent from my SM-N950U using Tapatalk

  4. #4
    New Member
    0%
    Rate Transaction

    Member #
    11455
    Medals
     
    Join Date
    Mar 2019
    Location
    Greenbrier
    State
    TN
    Country
    United States
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    Thanks! You guys rock! Now how about the funky boost?

  5. #5
    New Member 6 Rep Points
    0%
    Rate Transaction

    Member #
    9958
    Medals
     
    Join Date
    May 2018
    Location
    phenix city
    State
    AL
    Country
    United States
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    6


    Quote Originally Posted by grip grip View Post
    Thanks! You guys rock! Now how about the funky boost?
    If it's stock tune that just overboost, it holds 20/21 psi for 20 seconds during acceleration and then drops back down.

  6. #6
    New Member
    0%
    Rate Transaction

    Member #
    11455
    Medals
     
    Join Date
    Mar 2019
    Location
    Greenbrier
    State
    TN
    Country
    United States
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    Here's a quick video of the boost oscillation.



    Last edited by grip grip; 03-10-2019 at 09:26 PM.

  7. #7
    Member 39 Rep Points
    0%
    Rate Transaction

    Member #
    3591
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Sep 2015
    Location
    Chino Hills
    State
    CA
    Country
    United States
    Posts
    247
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    39


    Hmmm, I wonder if the Wastegate has been properly adjusted. Search the forum for "Wastegate adjustment", a specific thread should pop up. You will most likely have to dive in and check it out. Don't take my word for it, but definitely check

    Sent from my XT1650 using Tapatalk

  8. #8
    New Member
    0%
    Rate Transaction

    Member #
    11455
    Medals
     
    Join Date
    Mar 2019
    Location
    Greenbrier
    State
    TN
    Country
    United States
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    Quote Originally Posted by draxxus131 View Post
    Hmmm, I wonder if the Wastegate has been properly adjusted. Search the forum for "Wastegate adjustment", a specific thread should pop up. You will most likely have to dive in and check it out. Don't take my word for it, but definitely check

    Sent from my XT1650 using Tapatalk

    Thanks. After a few tries each way (loosened too much, and then didn't tighten back up enough) with the Wastegate rod it's much better. Obviously building boost slower now, but it's not surging up top as much now.

  9. #9
    Member 39 Rep Points
    0%
    Rate Transaction

    Member #
    3591
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    Sep 2015
    Location
    Chino Hills
    State
    CA
    Country
    United States
    Posts
    247
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    39


    You may not have a proper tune for the Wastegate, previous owner may have just slapped it on thinking it would be fine. Continue to check if the Wastegate is pre-loaded properly, and that the main nut is secured properly as well. Post up a day, some of the members could mull it over with you?

    Sent from my XT1650 using Tapatalk

  10. #10
    Member 168 Rep Points CSM's Avatar
    Ratings | Rate Transaction

    Member #
    2411
    Medals
    Earned First 100 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Mar 2015
    Location
    Charlotte
    State
    NC
    Country
    United States
    Posts
    486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    168


    Guest-only advertisement. Register or Log In now!
    OEM Wastegate is known for part throttle surging but not at WOT...thats almost certainly a rod adjustment issue. Also do you know what tune you are running? Some of the surging can be cured via tuning per my tuner (Dizzy)
    2014 Molten Orange
    Pwnall IC, Injen Intake, Boomba Recirculating BPV, Dizzy 93/E30 V2 tune
    Bilstein B14 PSS Coilovers, Hotchkis RSB, Sparco Pro Corsa+Indy 500
    Waiting to install: Pumaspeed X37+CPE Tune

 

 

Similar Threads

  1. Normal Boost few seconds then drops?
    By XuperXero in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 24
    Last Post: 02-03-2018, 11:17 PM
  2. Odd mpg & boost limit issue
    By eleven in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 9
    Last Post: 04-07-2017, 09:21 AM
  3. Boost drops - ECU caused?
    By SneakyPete in forum General Automotive Discussions
    Replies: 7
    Last Post: 02-13-2017, 04:41 PM
  4. Strange rev issue in neutral
    By Bp021590 in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 8
    Last Post: 09-06-2016, 10:00 PM
  5. Strange boost behavior
    By TuxedoST in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 5
    Last Post: 04-19-2016, 04:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •