Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

See the top rated post in this thread. Click here

User Tag List

Results 1 to 9 of 9
  1. #1
    New Member
    0%
    Rate Transaction

    Member #
    10841
    Medals
     
    Join Date
    Oct 2018
    Location
    Orlando
    State
    FL
    Country
    United States
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    Clicking behind speedometer/gauge cluster

    Guest-only advertisement. Register or Log In now!
    As the title suggests, I recently just noticed a clicking behind the gauge cluster/speedometer. I can't find any real pattern to it aside from it clicking when shifting or taking foot off the accelerator (it's typically just one or two clicks each time). It won't do it when the car is stationary (in gear or not). It's not coming from the blend door. Any ideas? Any help would be much appreciated!

  2. #2
    New Member 14 Rep Points
    0%
    Rate Transaction

    Member #
    10855
    Medals
     
    Join Date
    Nov 2018
    Location
    Mechanicsburg
    State
    PA
    Country
    United States
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    14


    how are you sure it's not the door blend actuator?

  3. #3
    New Member
    0%
    Rate Transaction

    Member #
    10841
    Medals
     
    Join Date
    Oct 2018
    Location
    Orlando
    State
    FL
    Country
    United States
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    Quote Originally Posted by camopaint0707 View Post
    how are you sure it's not the door blend actuator?
    Because it's still occuring with the air turned off, and it's not coming from the dash piece in front of the shifter...it's coming from directly behind my gauge cluster.

  4. #4
    New Member 14 Rep Points
    0%
    Rate Transaction

    Member #
    10855
    Medals
     
    Join Date
    Nov 2018
    Location
    Mechanicsburg
    State
    PA
    Country
    United States
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    14


    you know a video of it would go a long way. also the door blend isn't located behind the ac controls

  5. #5
    New Member
    0%
    Rate Transaction

    Member #
    10841
    Medals
     
    Join Date
    Oct 2018
    Location
    Orlando
    State
    FL
    Country
    United States
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    Quote Originally Posted by camopaint0707 View Post
    you know a video of it would go a long way. also the door blend isn't located behind the ac controls
    Haven't been able to reproduce it yet. I turned the car off and back on and it stopped. It wasn't the repetitive clicking on startup that most people see with the blend door. I'm aware it's not located behind the AC controls, but that panel next to it and the steering column is where the blend door sound typically comes from, and that's not where the sound I'm hearing is coming from.

  6. #6
    Member 199 Rep Points JDG's Avatar
    Ratings | Rate Transaction

    Member #
    7375
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Feb 2017
    Location
    Conshohocken
    State
    PA
    Country
    United States
    Posts
    550
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    199


    Turn your windshield wipers on with the engine not running, hear the relay clicking? Does it sound similar? It could be a mechanical relay.
    **Ask me about purchasing an Automatic Traction Control Off or Sport Mode On Module (Plug and Play)
    https://www.fiestastforum.com/forum/...Plug-and-Play)

    2016 Ford Fiesta ST - White Platinum / Recaros
    - Garrett GTX2860R Gen II Turbo, AET VUDU Ported Exhaust Manifold (41mm), Ported Turbo V-Band Adapter (41mm), Whoosh 3" Catted Downpipe, CP-E FMIC, Velossa Tech Big Mouth Snorkel, CP-E Intake, CP-E Cold Side Charge Pipe w/ Turbosmart BPV, and Cobb AccessPort (Stratified E30 & 93 Custom Tune
    - CP-E RMM, SkidPlateGuy Front Skid, NoPistons Evap Skid, Pierce Motorsports Midship Brace
    - 185/65R15 Maxsport RB3 Gravel Tires for Rally-X
    - 205/50R16 BFG Sport Comp 2 A/S for Daily Driving
    - 175/65R15 Michelin X-ICE XI3 for Winter

  7. #7
    New Member
    0%
    Rate Transaction

    Member #
    10841
    Medals
     
    Join Date
    Oct 2018
    Location
    Orlando
    State
    FL
    Country
    United States
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    1 Likes

    Quote Originally Posted by JDG View Post
    Turn your windshield wipers on with the engine not running, hear the relay clicking? Does it sound similar? It could be a mechanical relay.
    I do get that relay sound when I turn my wipers on and when I turn my seat heater on, but this sound is different (a little louder maybe?).

  8. #8
    Member 190 Rep Points LaserWhisperer's Avatar
    Ratings | Rate Transaction

    Member #
    4809
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Apr 2016
    Location
    Portland
    State
    OR
    Country
    United States
    Posts
    545
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    190


    Mine makes some clicking noises from behind the cluster too, been that way for 40K+ miles.
    No adverse operation noted as of yet

  9. #9
    New Member
    0%
    Rate Transaction

    Member #
    10841
    Medals
     
    Join Date
    Oct 2018
    Location
    Orlando
    State
    FL
    Country
    United States
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by LaserWhisperer View Post
    Mine makes some clicking noises from behind the cluster too, been that way for 40K+ miles.
    No adverse operation noted as of yet
    Good to know. I can't seem to recreate the sound. Hasn't come back since I turned the car off.

 

 

Similar Threads

  1. Gauge cluster crack!
    By shouldbeasy in forum Interior Upgrades & Modifications
    Replies: 3
    Last Post: 07-16-2018, 09:41 AM
  2. Gauge Cluster rattle/creak
    By NJohc in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 8
    Last Post: 09-19-2017, 03:31 PM
  3. Speedometer Cluster Removal
    By Mike V in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 1
    Last Post: 05-24-2017, 10:14 PM
  4. Wrench Light on my Gauge Cluster
    By dL_ST in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 53
    Last Post: 12-10-2016, 09:29 PM
  5. Gauge cluster changed?
    By __V__ in forum Interior Upgrades & Modifications
    Replies: 44
    Last Post: 08-20-2015, 07:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •