Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

User Tag List

Results 1 to 8 of 8

Thread: Boost issue
0 Likes

  1. #1
    New Member 21 Rep Points
    0%
    Rate Transaction

    Member #
    9078
    Medals
     
    Join Date
    Nov 2017
    Location
    Dripping Springs
    State
    TX
    Country
    United States
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    21


    Boost issue

    Guest-only advertisement. Register or Log In now!
    Greetings -

    I recently installed a GFB DV+ and Velossa Big Mouth. While at it, I tightened all the clamps on the Depo IC and hard pipes. I buttoned it all up, and the car was driving great, consistently hitting 26.5lbs boost on my Dizzy E30 tune. I filled up the car a few days later, and went for a spirited drive, only to find I would only hit about 23.5lbs, and on top of that, the boost would then taper off to redline, dropping as low as 12lbs. I've gotten back under the car and ensured all pipes are connected snugly and all clamps are tight.

    I cannot figure out what has happened... could the DV+ not be holding the seal properly?

    Supporting mods include Cobb intake, Whoosh Symposer delete, Thermal Exhaust and step colder plugs with less than 5k mi on them.

    Any ideas?
    2017 Magnetic Base
    Cobb Depo Whoosh Thermal R&D Swift Pierce Rally Armor GFB VelossaTech Dizzy Tuned

  2. #2
    Member 169 Rep Points kivnul's Avatar
    Ratings | Rate Transaction

    Member #
    4220
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points
    Join Date
    Jan 2016
    Location
    Deer Park
    State
    WA
    Country
    United States
    Posts
    524
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    169


    Is there a ambient temperature change?

  3. #3
    Senior Member 1176 Rep Points TyphoonFiST's Avatar
    Ratings | Rate Transaction

    Member #
    3563
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 2000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points Earned First 2000 Posts and 400 Rep Points
    Join Date
    Aug 2015
    Location
    Rich-fizzield
    State
    MN
    Country
    United States
    Posts
    4,066
    Mentioned
    44 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    1176


    Did you lube the piston before putting the DV back together?
    Is this your bush? Are you king of the forest?

  4. #4
    New Member 21 Rep Points
    0%
    Rate Transaction

    Member #
    9078
    Medals
     
    Join Date
    Nov 2017
    Location
    Dripping Springs
    State
    TX
    Country
    United States
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    21


    There has been an ambient temperature change, wherein, it's gotten about 15-20 degrees warmer, which should have the opposite effect (more boost for higher temps).

    I did lube the piston, but seeing as that is the only other thing I haven't checked at this point, I guess it is worth taking it off... it can come back apart right, without breaking anything?

    I should also do a data log and send to Jason at Dizzy... just haven't had the time or opportunity to get out and run it. Was just curious to get the collective thoughts of anything else I might have overlooked that might be causing this (vac lines all look normal and connected, etc).

    Thanks again for the feedback and I welcome others to chime in -
    2017 Magnetic Base
    Cobb Depo Whoosh Thermal R&D Swift Pierce Rally Armor GFB VelossaTech Dizzy Tuned

  5. #5
    Member 282 Rep Points Quisp's Avatar
    0%
    Rate Transaction

    Member #
    3955
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points
    Join Date
    Nov 2015
    Location
    Davenport
    State
    FL
    Country
    United States
    Posts
    975
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    282


    My first DV+ was galled up where the plunger passes through the body. It would only do 16lbs.I bought a replacement factory diverter and it took care of it. GFB warranted me a new one. Been no trouble for 30k.

  6. #6
    New Member 21 Rep Points
    0%
    Rate Transaction

    Member #
    9078
    Medals
     
    Join Date
    Nov 2017
    Location
    Dripping Springs
    State
    TX
    Country
    United States
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    21


    ^^Very interesting. I'll take the time to pull it off over the weekend... thanks for the feedback -

    Edit - just read the entire GFB DV+ thread... Hopefully I can diagnose if this is in-fact the issue -
    Last edited by Gimlet; 03-14-2019 at 10:05 AM.
    2017 Magnetic Base
    Cobb Depo Whoosh Thermal R&D Swift Pierce Rally Armor GFB VelossaTech Dizzy Tuned

  7. #7
    Member 40 Rep Points
    0%
    Rate Transaction

    Member #
    831
    Medals
    Earned First 100 Posts Earned First 25 Rep Points
    Join Date
    May 2014
    Location
    Dearborn Heights
    State
    MI
    Country
    United States
    Posts
    139
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    40


    Now just from what I have seen in the past is if you do not use a recirculating system it will hurt you holding boost. Especially in between shifts. Now besides that if you are making more torque it may be requesting less boost. Ecoboost engines have a torque goal so lets say the goal is 350Ft/lbs of torque. Then it will supply 10psi if that is what it will take or 20psi depending on what it needs to hit 350Ft/lbs.

  8. #8
    New Member 21 Rep Points
    0%
    Rate Transaction

    Member #
    9078
    Medals
     
    Join Date
    Nov 2017
    Location
    Dripping Springs
    State
    TX
    Country
    United States
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    21


    Guest-only advertisement. Register or Log In now!
    I was hitting damn near 300lbft of torque previously, but that has dropped down to about 240lbft now (estimates according to the AP3).
    2017 Magnetic Base
    Cobb Depo Whoosh Thermal R&D Swift Pierce Rally Armor GFB VelossaTech Dizzy Tuned

 

 

Similar Threads

  1. Replies: 9
    Last Post: 03-17-2019, 09:27 AM
  2. Possible Heatsoak Issue/Electrical. Lower boost levels
    By ChristianST in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 11
    Last Post: 10-08-2018, 12:35 AM
  3. Sometimes I loose boost completly, without check engine light. Restarting the car fixes the issue.
    By Peteros in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 10
    Last Post: 07-06-2018, 04:24 PM
  4. chirp noise from intake? boost issue possibly? [Video attached]
    By isimpoi in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 4
    Last Post: 01-26-2018, 07:30 PM
  5. Odd mpg & boost limit issue
    By eleven in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 9
    Last Post: 04-07-2017, 09:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •