Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

See the top rated post in this thread. Click here

User Tag List

Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    Senior Member 666 Rep Points Dpro's Avatar
    0%
    Rate Transaction

    Member #
    8838
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points
    Join Date
    Oct 2017
    Location
    Los Angeles
    State
    CA
    Country
    United States
    Posts
    1,388
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    666


    1 Likes

    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by TyphoonFiST View Post
    But what also runs through the center section of the Turbo? Coolant....so it's a possibility when it failed....it got some coolant into the exhaust or it got in during install or removal.

    Sent from my SM-N950U1 using Tapatalk
    Good point.
    2018 Orange Spice,Smoke Storm Recaro’s,Ebony wheels( for now) Thermal RD Exhaust
    , Cobb AP( tune by Randy af Mountune, more customs to come,)ST200 airbox with cold air intake,Revo foam filter, Whoosh/Ramair crossover pipe ,Whoosh Intake Tube,Turbosmart EV blowoff valve, Whoosh motorsports Symposer delete

  2. #12
    Senior Member 418 Rep Points
    Ratings | Rate Transaction

    Member #
    5184
    Medals
    Earned First 100 Posts Earned First 500 Posts Earned First 1000 Posts Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points Earned First 1500 Posts and 300 Rep Points
    Join Date
    Jun 2016
    Location
    South West Ohio
    State
    OH
    Country
    United States
    Posts
    1,553
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    418


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by hendrixsrv View Post
    I mean, the car was fine before I found out the turbo I bought had a bad seal. So I put the stock back in and oil and smoke is still spewing out of the exhaust. I didnt think a turbo swap would cause a gasket issue no?

    Sent from my SM-G955U using Tapatalk
    From your comments, we can guess that the turbo was swapped out under suspicion for being the source of oil and smoke out of the exhaust.

    What was your method for determining that the source of the leak was the turbo versus the engine? *Zero* residue in the exhaust headers, upwind of the turbo?
    2016 Ford Fiesta ST Kona Blue ; Engine, Suspension will remain untouched ; Southwest Ohio ; Winter: 215/45R17 Continental ; Seasonal: 205/40R17 Bridgestone

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 4
    Last Post: 11-25-2018, 12:27 PM
  2. Removed stock DV to install GFB, wrong GFB so I put back to stock - fluttering a lot now
    By Clit_Beastwood in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 5
    Last Post: 03-25-2018, 11:19 PM
  3. Upgrading to NAV from stock Sony Sync radio and adding stock back-up camera.
    By CarGuy in forum Audio-Video, Electronics, Sync & MyFord Touch
    Replies: 40
    Last Post: 08-10-2017, 12:40 PM
  4. Replies: 6
    Last Post: 06-19-2015, 11:34 PM
  5. Not giving up, putting one of these in my Duramax and pushing, digging, pulling for the ST......
    By RAAMaudio in forum Audio-Video, Electronics, Sync & MyFord Touch
    Replies: 1
    Last Post: 01-09-2015, 10:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •