Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

See the top rated post in this thread. Click here

User Tag List

View Poll Results: Who has had blend door actuator problems?

Voters
211. You may not vote on this poll
  • '14 Fiesta ST

    80 37.91%
  • '15 Fiesta ST

    76 36.02%
  • '16 Fiesta ST

    46 21.80%
  • '17 Fiesta ST

    9 4.27%
Page 39 of 40 FirstFirst ... 2931323334353637383940 LastLast
Results 381 to 390 of 394
  1. #381
    New Member
    0%
    Rate Transaction

    Member #
    10559
    Medals
     
    Join Date
    Sep 2018
    Location
    Naples
    State
    FL
    Country
    United States
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by HBEcoBeaST View Post
    Woo hoo! Took me about 45min. A thumb ratchet is a lifesaver. Got the idea from this forum. Thanks guys!

    Sent from my Pixel 2 using Tapatalk
    Just pulled out the actuator on my wife's ST but I'm having a problem installing the new one. It seems that the spline on the actuator is not inserting completely. I have read in the forum of some posters discussing "homing" of this offensive part. I'm not sure I know what this means or involves. Also, there seems to be an alignment tab on this part. Am I correct in this? Any tips on getting this sucker back in would be really appreciated.

  2. #382
    Member 95 Rep Points HBEcoBeaST's Avatar
    0%
    Rate Transaction

    Member #
    7918
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points  
    Join Date
    May 2017
    Location
    Huntington Beach
    State
    CA
    Country
    United States
    Posts
    399
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    95


    Quote Originally Posted by gaussianmist View Post
    Just pulled out the actuator on my wife's ST but I'm having a problem installing the new one. It seems that the spline on the actuator is not inserting completely. I have read in the forum of some posters discussing "homing" of this offensive part. I'm not sure I know what this means or involves. Also, there seems to be an alignment tab on this part. Am I correct in this? Any tips on getting this sucker back in would be really appreciated.
    Insert the white gear into the hole whichever way it fits. While it's inserted rotate the unit so the alignment holes line up.

    Mine would not fit if I just tried to go by the mounting points

    Sent from my Pixel 2 using Tapatalk

  3. #383
    New Member 16 Rep Points
    0%
    Rate Transaction

    Member #
    733
    Medals
     
    Join Date
    May 2014
    Location
    Somewhere
    State
    NV
    Country
    United States
    Posts
    77
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    16


    I had this problem last year. I feel better and also worse that it wasn’t just me though.

  4. #384
    New Member
    0%
    Rate Transaction

    Member #
    4684
    Medals
     
    Join Date
    Mar 2016
    Location
    Albany
    State
    NY
    Country
    United States
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    My 2016 Fist is at the dealer for tapping in the middle of the dash. Was told it was a big job, dash has to come out. ProDemand shows 3 actuators. 1 shows 1 hour labor, another is .5 hour and the third is 5 hours.I guess mine is the last. Hope the dash does not rattle or squeak after, it has been quiet before. The dealer provided a Focus as a loaner, no fun. Supposed to be done Wednesday.

  5. #385
    New Member
    0%
    Rate Transaction

    Member #
    10577
    Medals
     
    Join Date
    Sep 2018
    Location
    Troy
    State
    AL
    Country
    United States
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    1


    My 2017 has started clicking like crazy from the center of the dash with only 1700 Miles on it. I knew to expect this issue but didn’t realize I’d encounter it within the first three weeks of owning the car.

  6. #386
    New Member
    0%
    Rate Transaction

    Member #
    4684
    Medals
     
    Join Date
    Mar 2016
    Location
    Albany
    State
    NY
    Country
    United States
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    4


    The saga continues, yesterday I was told the part was in and would be done today. Service advisor called, they ordered the wrong part. Car is still apart. Said it was a big job. May have to buy the Ford warranty.

  7. #387
    Member 73 Rep Points
    Ratings | Rate Transaction

    Member #
    9334
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points  
    Join Date
    Jan 2018
    Location
    lakewood
    State
    CA
    Country
    United States
    Posts
    252
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    73


    ford should recall all of these with a better idea.

  8. #388
    Member 122 Rep Points
    0%
    Rate Transaction

    Member #
    8222
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Jul 2017
    Location
    Menifee
    State
    CA
    Country
    United States
    Posts
    668
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    122


    With this many failures, some failing twice is absurd. They should at least try metal gears. I heard there was a crown vic one with metal gears that worked.

    Sent from my SM-G965U using Tapatalk

  9. #389
    Member 76 Rep Points SPhilli911's Avatar
    0%
    Rate Transaction

    Member #
    2002
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points  
    Join Date
    Dec 2014
    Location
    Hartford
    State
    CT
    Country
    United States
    Posts
    317
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    76


    Just came across this issue today for the first time, wonderful. Started clicking this morning and kinda freaked me out, I wasn't aware of this issue on Fords until looking it up. Bought the new part and I will try to fix it myself this weekend, doesn't seem too hard, thanks to that video someone posted.

    My car is a 2015 car, got about 35,000 miles on it.

  10. #390
    Senior Member 856 Rep Points TyphoonFiST's Avatar
    Ratings | Rate Transaction

    Member #
    3563
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points  
    Join Date
    Aug 2015
    Location
    Blaine
    State
    MN
    Country
    United States
    Posts
    3,085
    Mentioned
    33 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    856


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by SPhilli911 View Post
    Just came across this issue today for the first time, wonderful. Started clicking this morning and kinda freaked me out, I wasn't aware of this issue on Fords until looking it up. Bought the new part and I will try to fix it myself this weekend, doesn't seem too hard, thanks to that video someone posted.

    My car is a 2015 car, got about 35,000 miles on it.

    Arent you still just under factory 3yr/36k? Food for thought.....
    Is this your bush? Are you king of the forest?

 

 
Page 39 of 40 FirstFirst ... 2931323334353637383940 LastLast

Similar Threads

  1. Blend door actuator.
    By Ellis65301 in forum Maintenance, Warranty Issues & Troubleshooting
    Replies: 1
    Last Post: 10-16-2016, 10:15 AM
  2. How do you adjust the door gap? door slightly ajar
    By Dib in forum Exterior Cosmetic & Lighting Modifications
    Replies: 0
    Last Post: 06-10-2016, 09:33 PM
  3. Replies: 18
    Last Post: 11-11-2015, 04:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •