• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!

Ecu problem???

OP
J
Messages
20
Likes
3
Location
Whitehaven, UK
Thread Starter #3
Car runs fine for about an hour then just dies like jitters and splutters then wont start again until u leave it for few hours and eml is intermittent codes that are showing are coming up to fuel related problems so changed all the pumps in the car changed the fuel rail sensor changed the moduel for the fuel pump changed fuel line and still the same now the garage is sayin it can only be the ECU because of the map so if I get it remapped do u think it will work answers much appreciated..
 

Clit_Beastwood

Senior Member
Messages
971
Likes
546
Location
Laguna beach
#4
Car runs fine for about an hour then just dies like jitters and splutters then wont start again until u leave it for few hours and eml is intermittent codes that are showing are coming up to fuel related problems so changed all the pumps in the car changed the fuel rail sensor changed the moduel for the fuel pump changed fuel line and still the same now the garage is sayin it can only be the ECU because of the map so if I get it remapped do u think it will work answers much appreciated..
Can't you revert back to a stock map? I have a Cobb access port that backed up my stock map when I first switched, so I can always flip back. It should only take you a few minutes to flash back to stock I think. You might want to verify that UK fiestas are the same before you do it though - I am not familiar enough to know.
 

CanadianGuy

4000 Post Club
Messages
4,098
Likes
914
Location
Southern Ontario
#5
Car runs fine for about an hour then just dies like jitters and splutters then wont start again until u leave it for few hours and eml is intermittent codes that are showing are coming up to fuel related problems so changed all the pumps in the car changed the fuel rail sensor changed the moduel for the fuel pump changed fuel line and still the same now the garage is sayin it can only be the ECU because of the map so if I get it remapped do u think it will work answers much appreciated..

Had a very similar problem the code was ecu and throttle body. The issue was the throttle body. It was not indicating the correct spot compared to the requested. Could give that a shot first.
 
OP
J
Messages
20
Likes
3
Location
Whitehaven, UK
Thread Starter #6
Thankyou for replying iv just got the car back from another garage had the map taken off and the ECU put back to standerd and the car still cuts out 🤮
 

Similar threads



Top