• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!

NEED HELP WITH THIS CODE

Messages
11
Likes
0
Location
Buckie, UK
#1
H People,

Need help with these codes, been told it’s 100% a boost leak then been told it’s the MAP sensor needing replaced?

I have replaced MAP sensor and still the same

I haven’t carried out a smoke test etc yet but just wanting to see what people’s opinions are on it?

It comes in at very random times, you could be driving for 200 and it won’t come on then it will come on when you put the foot down, then sometimes you can drive 20 mile and it comes on like 2 times?

It weird and can’t seem to figure out what it could be, recently fitted a boost gauge and it only came on after this and i’ve put PTFE tape on the threads on the adapter and everything just unsure on what it is.
 


Hypergram

1000 Post Club
Premium Account
Messages
1,303
Likes
847
Location
Orlando, FL, USA
#2
Can you tell us what the code is? In the US we have Accessports that will tell us what fault code it is which helps narrow down the issue. Do you have access to something like that in the UK?

Besides that my best guess is to take off the boost gauge and see if it goes away ¯\_(ツ)_/¯
 


Last edited:

D1JL

6000 Post Club
Staff Member
Premium Account
Messages
6,816
Likes
2,686
Location
SFV, So.Cal.
#3
Although many here will try to help and do what they can.
Be advised the US and UK cars are different however, I am sure one or more of our UK members will help you.
 




Top