Welcome to Fiesta ST Forum, is this your first visit? Click the "Create Account" button now to join.
Register

See the top rated post in this thread. Click here

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Vendor Premier Vendor 124 Rep Points
    0%
    Rate Transaction

    Member #
    8288
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Jul 2017
    Location
    Rocky Point
    State
    NY
    Country
    United States
    Posts
    139
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    124


    6 Likes

    What is this part-throttle surge you speak of?

    Guest-only advertisement. Register or Log In now!
    I wanted to start a new thread for this discussion, as to not derail any of my other threads.

    I have had isolated reports of what I like to call a “part-throttle surge” on the Dizzy Tuning Fiesta Flash Tune. You can reproduce this surge by going into 3rd, 4th, 5th (or really any) gear, with the RPM around 2,000. If you then lay into it fairly aggressively, but only to about 60% throttle position, and hold the pedal there. You will experience a surging, regardless of the intake or exhaust modifications. Aftermarket intakes that are much noisier, will make the issue much more pronounced/audible. Testing with aftermarket actuators is coming soon, but I have confirmed it is NOT the actuator causing the surge.

    I also want to state up front that my Flash Tune is not the only calibration that exhibits this behavior. I have confirmed that it is present in the Cobb OTS maps (v500, I have not yet tested the v504 for this phenomenon), as well as other Protuner maps. I will not go into much detail here, but have spoken with numerous customers using various other tunes, and they have noticed it as well. I do think the intensity of this surge may vary by tuner, but it is always still there (in my opinion, and I have seen datalogs).

    So what causes this surge, and why has no one addressed it? This is something I have been working on over the past few months, and plan to implement in my upcoming Fiesta Flash Tune V2!

    Let’s go into a little more detail, shall we. The ECU uses what is called a torque (or load) targeting strategy, rather than the old school boost targeting strategy. Torque targeting is fantastic because it allows your engine to run consistently in virtually all weather conditions. Some of you may notice that your boost values may be slightly lower in the winter, and higher in the summer. This is cause the colder denser air requires less boost to achieve the same torque values that it would have in the warmer months with higher boost levels. But the overall underlying issue (in my opinion) is the overly aggressive torque targeting tables, coupled with a VERY small turbo that spools almost instantaneously.

    So if we think about the processes in slow motion, it would look something like this:

    • You press the accelerator pedal aggressively, while rolling at a constant rpm
    • The ECU uses the Throttle Requested Torque tables to lookup/determine what torque we want to achieve, based on current RPM and APP
      (The tables are aggressive, so they request a high torque value)
    • The throttle opens abruptly and the wastegate closes, spooling the turbo
    • You then overshoot your torque lookup target in the Throttle Requested Torque tables, due to the initial overly aggressive target
    • Now the ECU closes the throttle and reduces boost, via the wastegate
    • The process may repeat depending on the above conditions



    So how can we fix this? We can modify the Throttle Requested Torque tables to target torque more appropriately based on turbo size and flow modifications on the vehicle. The result is smooth ETC (Electronic Throttle Control) operation that more closely matches APP (Accelerator Pedal Position). Stay tuned!
    Attached Images Attached Images  

  2. #2
    Member 55 Rep Points
    Ratings | Rate Transaction

    Member #
    4189
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points  
    Join Date
    Dec 2015
    Location
    Baton Rouge
    State
    LA
    Country
    United States
    Posts
    171
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    55


    Yeah, this is a thing. I have had this happen on most (all?) off the shelf tunes as well as a custom pro-tune. I've seen it on stock turbos, hybrid turbos, and big turbos. Most common on the stock and hybrids. When I noticed it once in the log on my personal car, I just requested my tuner to look at it...fixed on the next revision. It only seems to pop up at high throttle in certain gears at a specific RPM window. We have a really old thread somewhere talking about the saw-tooth throttle blade behavior before and how to improve or dampen it for "self" tuners, but we've never had a vendor address it before.

    Thanks.

  3. #3
    Vendor Premier Vendor 124 Rep Points
    0%
    Rate Transaction

    Member #
    8288
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Jul 2017
    Location
    Rocky Point
    State
    NY
    Country
    United States
    Posts
    139
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    124


    I think you are referring to this thread, which discusses throttle closures at wot.

    https://www.fiestastforum.com/forum/t...-automatically

  4. #4
    Senior Member 454 Rep Points
    0%
    Rate Transaction

    Member #
    8050
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points  
    Join Date
    Jun 2017
    Location
    Spring
    State
    TX
    Country
    United States
    Posts
    1,212
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    454


    I can confirm that this happened on brand A's tune but doesn't on brand B. Great explanation Jason. I agree it's not a bad thing, albeit slightly annoying to the driver. My passengers never even noticed it and to be honest, I only really noticed it when I had the AP hooked up with boost level as a bar graph and I saw it bouncing up and down. It was almost imperceptible in the seat.

  5. #5
    Member 200 Rep Points shouldbeasy's Avatar
    0%
    Rate Transaction

    Member #
    1015
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points  
    Join Date
    Jun 2014
    Location
    Calgary
    Country
    Canada
    Posts
    795
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    200


    2 Likes

    Had this happen on my Stratified tune, mentioned it and it was addressed (significant improvement) but I still feel it occasionally (X-47 Turbo).

  6. #6
    New Member 18 Rep Points
    0%
    Rate Transaction

    Member #
    9078
    Medals
     
    Join Date
    Nov 2017
    Location
    Dripping Springs
    State
    TX
    Country
    United States
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    18


    1 Likes

    I can also say I have felt this phenomena. I thought perhaps I had a bad tank of gas, cleaned my MAF sensor, etc. Reassuring to see it's not an isolated incident on my side. TBT, it's not annoying, and only happens when say accelerating on a curvy back road where I don't want to give it the full beans, but still want to move quickly.

    Jason- if you get this sorted, will you be offering a v2 update at a discount for those with the older tune?

  7. #7
    Vendor Premier Vendor 124 Rep Points
    0%
    Rate Transaction

    Member #
    8288
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Jul 2017
    Location
    Rocky Point
    State
    NY
    Country
    United States
    Posts
    139
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    124


    Quote Originally Posted by Gimlet View Post
    I can also say I have felt this phenomena. I thought perhaps I had a bad tank of gas, cleaned my MAF sensor, etc. Reassuring to see it's not an isolated incident on my side. TBT, it's not annoying, and only happens when say accelerating on a curvy back road where I don't want to give it the full beans, but still want to move quickly.

    Jason- if you get this sorted, will you be offering a v2 update at a discount for those with the older tune?
    Absolutely. It will either be a small fee to update, or I will offer it at no charge (for existing customers).

  8. #8
    Member 174 Rep Points LaserWhisperer's Avatar
    Ratings | Rate Transaction

    Member #
    4809
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points  
    Join Date
    Apr 2016
    Location
    Portland
    State
    OR
    Country
    United States
    Posts
    498
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    174


    1 Likes

    I'm also experiencing some surging at part throttle, we can discuss more when I send in datalogs :-)

  9. #9
    Member 80 Rep Points CSM's Avatar
    Ratings | Rate Transaction

    Member #
    2411
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points  
    Join Date
    Mar 2015
    Location
    Atlanta
    State
    GA
    Country
    United States
    Posts
    268
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Likes Received
    80


    I've got this on my V2 93 octane tune. Its pretty mild, but still there.

    FWIW My car always did this even when I had the MP215 tune on there as well.
    2014 Molten Orange
    Pwnall IC, Dizzy Stage 2 tune, Injen Intake
    Boomba Recirculating Mechanical BPV, Sparco Pro Corsa+Indy 500

  10. #10
    Senior Member 948 Rep Points TyphoonFiST's Avatar
    Ratings | Rate Transaction

    Member #
    3563
    Medals
    Earned First 25 Rep Points Earned First 50 Rep Points Earned First 100 Rep Points Earned First 200 Rep Points  
    Join Date
    Aug 2015
    Location
    Blaine
    State
    MN
    Country
    United States
    Posts
    3,276
    Mentioned
    33 Post(s)
    Tagged
    1 Thread(s)
    Likes Received
    948


    Guest-only advertisement. Register or Log In now!
    Quote Originally Posted by Gimlet View Post
    I can also say I have felt this phenomena. I thought perhaps I had a bad tank of gas, cleaned my MAF sensor, etc. Reassuring to see it's not an isolated incident on my side. TBT, it's not annoying, and only happens when say accelerating on a curvy back road where I don't want to give it the full beans, but still want to move quickly.

    Jason- if you get this sorted, will you be offering a v2 update at a discount for those with the older tune?
    I thought our cars were speed density? Or am I wrong? What was the fix for this issue? anyone solve it?
    Is this your bush? Are you king of the forest?

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •