• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!

AiM Solo 2 DL not connecting to ECU

Messages
71
Likes
29
Location
DFW
#1
So I just picked up an AiM Solo 2 DL to get better data from track days. I bought the Solo 2 DL because it is supposed to connect to the ECU and record things like throttle position, brake pressure, water temperature, individual wheel speeds, etc.

Unfortunately, at my event this last weekend I wasn't getting any readings from the ECU. I tried both the Fiesta ECU driver that AiM's site says will work on Fiestas "from 2008 onward" and a generic OBDII driver. Neither would show data on the Solo or on my laptop when I was connected to the Solo.

Has anyone set up one of these lap timers before? I would really like to be able to make the all the *pretty graphs* and other data analysis things the cool kids do.
 
OP
Questionable
Messages
71
Likes
29
Location
DFW
Thread Starter #2
I solved this issue after talking to AiM support and sending in my unit and ODBII harness. Turns out my harness was bad, so AiM replaced it and sent everything back to me.

I had another event this last weekend and I have data from the ECU.

One thing that came up when taking with AiM was the OBDII driver and their Italian department/engineers confirmed that the 2008 Fiesta ST driver is the one to use. It has a lot of data, but not everything works (oil pressure telltale was a particular monitor I was hoping to get).

I set up my Solo to just show water temperature and use the LEDs on the side to act as shift lights. It all worked perfectly. This beats using my phone, even if video integration is going to be more involved.

Sent from my H8314 using Tapatalk
 


Top