• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!

Help needed: Fiesta ST throttle cutting out while driving intermittently

Messages
1
Likes
0
Location
Johannesburg, South Africa
#1
Good day everyone. I need some help with my Fiesta ST. Here's the summary of my troubles:

2017 Ford Fiesta ST, Euro spec, South Africa
Mods: Downpipe, exhaust, stage 1 software


P083F
"clutch pedal switch A/B correlation"
P2121
"Throttle/pedal position sensor/switch 'D' circuit range/performance"


Randomly and intermittently, the car will go into limp mode for a couple of seconds. It happens only when under light throttle or when pulling off in first gear. Sometimes, the engine actually cuts out and the screen displays the "press clutch to turn on" message as if I stalled it (I'd be moving at a constant speed, in gear, and it would do this then go back to normal. I don't suspect it actually shut off)

It's only been happening after I hit a large pothole and dented my wheel.

Sometimes it will also stall/cut out properly when not in gear, or it'll drop revs then go back to normal right after.

It seems as if the car is perfectly fine. Performance is normal, all electronics are normal. I even replaced the battery, which didn't help at all.

Possibly unrelated, I am hearing a slightly clunking noise by the driver side footwell/front right wheel when stationary as if driving slowly over small and loose stone bricks. It also seems to get louder when I'm pulling off. I'm suspecting that my driver side mount is shot.

No check engine light, only when it does the weird stall/no power with throttle for a couple of seconds, right after it turns off. No DTC's. However, the codes listed above were from continuous memory of the PCM. But I cleared them, and the no power moments stopped for a bit, but now came back.

I have a couple of theories: the throttle pedal is toast; the wiring loom for the clutch switch and throttle pedal probably is slipping out every so often (roads are bumpy here); maybe a ground connection is shorting somewhere ; a wire is loose on the ecu.

Any help will be greatly appreciated!
 


XR650R

1000 Post Club
Premium Account
Messages
1,318
Likes
1,095
Location
Eerie
#2
I'd go over all the wires first, too. That clunk may very well be a broken mount. They happen.
 


Intuit

2000 Post Club
Messages
2,202
Likes
820
Location
South West Ohio
#3
Noise may be tie-rod end or ball-joint, particularly if that's the side that took the crater and dented the wheel. In my experiences with a past vehicle, pushing/pulling on the wheel, with it in the air, wasn't enough to detect such issues. Only in removing and inspecting the parts, did I confirm the damage. (in which case, may as well swap it out anyway)

P083F
"clutch pedal switch A/B correlation"
P2121
"Throttle/pedal position sensor/switch 'D' circuit range/performance"
First probably means, one of the two clutch switches at the top/bottom of pedal travel, wasn't operated or detected.
Second one is likely responsible for the limp-mode issue.

The two sensors probably have a common wire harness. Trace from the sensors back to the harness and inspect for anomalies.
 


Similar threads



Top