• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!

Any ideas why it won't start and does this...?

Messages
160
Likes
53
Location
So Cal
#2
How is your battery?
Mine would do that when my battery was close to the end of its life.
 


Rocketst

1000 Post Club
Messages
1,203
Likes
725
Location
Chesapeake, VA, USA
#3
If you haven't touched the starter, starter is probably dead. Year of car? Miles? Also, could be battery like stated above.

Sent from my moto z4 using Tapatalk
 


OP
cxwrench
Messages
491
Likes
278
Location
Marin County
Thread Starter #4
It's a year old battery. But...I have been leaving my dash cam plugged in. I'd be surprised if that draws enough juice to kill the battery, right? I've got it on the charger now and it was down to below 10%. I'll charge it up and then go to the battery place I got it from and see what they have to say.
 


Messages
190
Likes
133
Location
Michigan
#7
Yep battery. Mine did that when I left my AP plugged in and didn't drive it for a week durning the first part of the stay at home order.
 


M-Sport fan

9000 Post Club
Messages
11,485
Likes
4,143
Location
Solebury, Pa.
#9
When my factory Motorcraft battery gave up the ghost, that is EXACTLY how the dash 'behaved' (or MISbehaved!). [:(]
 


Rocketst

1000 Post Club
Messages
1,203
Likes
725
Location
Chesapeake, VA, USA
#10
You know what, another thing... How far do you drive the car usually? If you don't get very man highway miles and it's a short drive to work you could also be killing the battery before it has a chance to recharge.

Sent from my moto z4 using Tapatalk
 


M-Sport fan

9000 Post Club
Messages
11,485
Likes
4,143
Location
Solebury, Pa.
#11
You know what, another thing... How far do you drive the car usually? If you don't get very man highway miles and it's a short drive to work you could also be killing the battery before it has a chance to recharge.

Sent from my moto z4 using Tapatalk
Precisely why I charge my Odyssey 96R-600 once a week as a precaution, as sometimes, when I connect the charger it is only showing an 80% charge, and low 12s on voltage. [wink]
 




Top