• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Fiesta ST Forum and Fiesta ST community dedicated to Fiesta ST owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Fiesta ST Forum today!


CEL P0456 P1450

Messages
7
Likes
5
Location
Fresno, CA, USA
#1
I'm not sure what else could be the problem with P0456 since I recently replaced the purge valve assembly about 5k miles ago when I got a CEL for it. It went away on its own before I replaced the assembly, but I went ahead and replaced it anyway (which ended up solving a separate issue: wanting to stall after fill-up). Could it be a problem with the capless fuel filler? I shoved a funnel in and out of it to see if it just didn't close correctly the last time I filled up. Time will tell if this worked.

As for P1450, is this related to P0456 in this case? The only thing I found about it was this post:

https://www.fiestastforum.com/threads/engine-code-p1450.22374/

Any suggestions on how to approach these would be appreciated. For now I will wait and see if poking the fuel cap fixed it.
 


TyphoonFiST

9000 Post Club
Premium Account
Messages
11,506
Likes
8,005
Location
Rich-fizzield
#2
I'm not sure what else could be the problem with P0456 since I recently replaced the purge valve assembly about 5k miles ago when I got a CEL for it. It went away on its own before I replaced the assembly, but I went ahead and replaced it anyway (which ended up solving a separate issue: wanting to stall after fill-up). Could it be a problem with the capless fuel filler? I shoved a funnel in and out of it to see if it just didn't close correctly the last time I filled up. Time will tell if this worked.

As for P1450, is this related to P0456 in this case? The only thing I found about it was this post:

https://www.fiestastforum.com/threads/engine-code-p1450.22374/

Any suggestions on how to approach these would be appreciated. For now I will wait and see if poking the fuel cap fixed it.
Did this work out for you? i popped a p1450 today driving along
 


OP
D
Messages
7
Likes
5
Location
Fresno, CA, USA
Thread Starter #3
So a couple months of contemplating (and laziness) later, I've figured it out.

Bad purge valve...again.

I threw a new assembly (D2BZ-9C047-E) on a couple days ago as I was 90% sure this was the culprit and waited for the CEL to clear. The light just cleared up today. I'll scan it again to see if everything checks out, if something else is up I'll make sure to update this post. If you don't see anything else on this thread, it's likely that everything is ok.

I've held on to my old purge valve assembly to see if using a heat gun will get the purge valve out. I really don't feel like spending $180 every time this thing goes out, so if I can replace just the valve itself for about $30 that would be better.

As for code P1450, I think this code goes hand in hand with P0456. I remember when the first time my purge valve went out both of these codes came up. After fixing it, both codes went away. But if you happen to pop that code on its own, I wouldn't know where to start other than the thread I linked in the original post.
 




Top